
 

 

 

 

 

 

 

 

第3章  ANSYS用于信号完整性

分析的 EDA 软件 
 

 

3.1  ANSYS 的 EDA 软件简介 

ANSYS 电子自动化设计（EDA）软件，来自于著名的 Ansoft 公司，提供业界唯一完整

的系统、电路和电磁场全集成化设计平台，完成从部件设计、电路仿真优化到系统仿真验证的

全过程。作为 ANSYS 电子设计产品中的电路与电磁场工具，实现了与 ANSYS 仿真产品的

无缝集成，可方便流畅地实现电磁场、电路、系统、流体、结构、热及应力的协同设计，全面

仿真真实的物理世界，帮助用户实现创新性的设计，推动产品研发。作为业界唯一完整的系统、

电路和电磁场全集成化设计平台，ANSYS 的 EDA 产品在高频和低频电磁场仿真、时域/频域

非线性电路仿真、机电一体化设计技术等方面始终处于领导地位，广泛应用于各类高性能电子

设备的设计，包括了航空、航天、电子、国防、集成电路、通讯、电机、汽车、船舶、石油、

医疗仪器及机电系统设计，应用领域覆盖了网络设备与宽带部件，雷达、通信与电子对抗系统，

集成电路（IC），印刷电路板（PCB），医疗电子系统，汽车电子系统，伺服与控制系统，供电

系统和高低压电气，开关电源和电力电子系统，EMI/EMC 设计等多个方面。 

ANSYS 的 EDA 软件用于信号完整性分析的工具包括： 

HFSS：三维高频结构全波电磁场仿真，对高速信号通道中的 PCB、过孔、封装、连接器、

电缆等进行精确的全波仿真、设计与建模，仿真机箱/机柜的屏蔽效能、谐振特性和 PCB 系统

的辐射特性。 

SIwave：PCB 板和封装信号完整性/电源完整性和 EMI/EMC 设计仿真工具，采用有限元

法直接仿真复杂的 PCB 结构，得到 PCB 电源/地平面的谐振特性、完备的信号线传输模型、

供电阻抗、直流压降、近场和远场辐射等特性。 

Designer：高速系统设计和仿真环境，可以动态连接和直接调用三维电磁场仿真、PCB 电

磁场仿真、电路仿真及测试数据，进行高速信号通道和 PCB 工作特性仿真。 

3



ANSYS 信号完整性分析与仿真实例  

 32 

Q2D（SI2D）/Q3D Extractor：二维和三维结构准静态电磁场仿真工具（Q2D 以前称 SI2D），

直接计算并抽取连接器、封装、电缆、线束结构的电阻、电容和电感参数，生成 SPICE 等效

电路模型，进行封装、电缆、线束和连接器的设计和模型抽取。 

TPA：BGA 封装专用快速参数提取工具。 

ANSYS 高性能 SI/PI 和 EMI/EMC 设计工具不仅拥有业界最好的电磁场仿真技术，还有领

先的电路/系统仿真能力，能够将全波 S 参数互连结构寄生效应、驱动器和接收器的非线性模

型包括在内，进行精确而完备的仿真，从容应对复杂的高性能电子设备和数模混合电路中的信

号完整性（Signal Integrity，SI）和电源完整性（Power Integrity，PI）问题，包括芯片内部互

连结构、芯片与封装、封装与 PCB、PCB 与连接器和电缆/线束以及系统的传输特性，数模隔

离与干扰，PCB 辐射与屏蔽，直流压降等，确保系统的性能。按照图 3.1 所示的 ANSYS 集成

化高速系统设计平台，能够方便地管理多种来源的数据，实现协同设计与仿真。 

 

图 3.1  ANSYS 集成化的高速系统设计平台 

3.2  HFSS 软件 

3.2.1  HFSS 概述 

HFSS（High Frequency Structure Simulator）作为行业标准的电磁仿真工具，特别针对射频、

微波以及信号完整性设计领域。由图 3.2 所示的 HFSS 仿真技术可知，作为基于频域有限元技

术的三维全波电磁场求解器，HFSS 可提取散射参数，显示三维电磁场图，生成远场辐射方向
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图，以及提供全波 SPICE 模型，该模型可用在 Designer 和其他信号完整性分析工具中。针对

封装和 PCB 板上高速串行信号的信号完整性问题，工程师可以使用 HFSS 轻松地设计并评估

连接器、传输线及 PCB 上的过孔，高速元件引起的信号完整性和电磁干扰性能。最新版本的

HFSS 除了提供频域有限元电磁场求解器，还增加了积分方程求解器 IE，以及时域有限元电磁

场求解器 HFSS-Transient，使得求解电磁场问题的规模和效率进一步提高。 

 

图 3.2  HFSS 仿真技术 

3.2.2  功能简介 

HFSS 提供三维建模、电磁场仿真和结果后处理集成化环境，可以广泛用于微波天线、波

导、滤波器、信号完整性和电磁兼容等领域的仿真。独有的自适应网格剖分和丰富的边界条件

设置，能确保求解精确稳定，使得初学者能够与资深使用者一样，方便简单地得到精确的分析

结果。 

3.2.3  HFSS 在信号完整性分析中的作用 

HFSS 是功能强大的任意三维结构电磁场全波仿真设计工具和 EMI 集成仿真验证环境。

HFSS 可以对设计中的任意三维结构进行从直流到几十 GHz 范围的全波分析，以 S 参数显示，

用于分析信号的传输、反射及匹配特性，计算辐射、色散、模式转换和材料频变效应等对信号

传输的影响，如整个电子设计系统高速关键路径，包括：子电路板/背板的高速信号线、过孔、

电缆、封装、连接器等，并进一步设计和优化。HFSS 也可以配合 SIwave 和 Q3D 和 Ansoft 

Designer 使用，用于分析机箱机柜环境中，一个或多个 PCB 单板、电源部件和线束线缆的屏

蔽效应和对外的 EMI 辐射，从而考察机箱材料、结构和开槽等对系统 EMI 辐射的影响。 
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3.2.4  工作窗口 

观察如图 3.3 所示的 HFSS 工作窗口可知，HFSS 是基于 Windows 操作风格的界面，将项

目管理窗口（Project Manager）、建模窗口（Modeler），以及属性（property）、信息（message）、

进程（process）等辅助窗口集成在一个界面下。所有的操作都可以通过菜单、工具栏、对话框，

鼠标右键等方式快捷操作。 

 

图 3.3  HFSS 的工作窗口 

3.2.5  基本操作 

HFSS 在安装完成后，桌面出现如下图标。 

 
双击打开后，选择求解类型。对于绝大多数 SI 问题，都使用频域有限元求解器，因此选

择 Project→Insert HFSS Design，或者图标 。 

HFSS 的仿真流程可以由图 3.4 概括。 

开始一个项目后，首先要选择仿真类型。HFSS 包含四种基本仿真类型：Driven Modal、

Driven Terminal、Eigen Mode、Transient，可以根据设计需要选择不同的求解类型。Driven Model

和 Driven Terminal 都是在有源驱动（可理解为需要端口激励）的情况下的求解类型。其中 Driven 

Modal 求解类型的典型应用在微带线、波导等传输线结构，采用这种求解类型得到的 S 参数是

基于主模到高次模的各种模式的广义 S 参数；Driven Terminal 求解类型的典型应用在终端为多

 
Menu bar 

Project  
Manage  

with project  
tree 

Property Window 

Message  
Manager 

Status  
bar 

Coordinate Entry Fields

Progress 
Window

3D Modeler 
Window
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根导体的传输线，比如差分线，这种端口需要定义终端线，求解得到的 S 参数是基于终端的，

例如差分线可得到差模及共模的 S 参数值。对于天线和微波器件的仿真多用 Driven Model，而

Driven Terminal 在电路、高速互连设计中用得较多，一般的 SI 问题，大多选择 Driven Terminal

方式，如图 3.5 所示。 

 

图 3.4  HFSS 仿真流程 

HFSS 为用户提供一个方便的三维绘图建模环境，既可以在其中画出分析对象的三维结构，

输入材料参数，进行仿真分析，也可以导入 AutoCAD、Pro/E、STEP、IGES、ACIS 等机械结构

设计文件，或者通过 AnsoftLinks 导入 PCB 或封装的局部模型，设置材料和边界条件后直接做

仿真。仿真结果可以是坐标系下的辐射场量，也可以是三维或动画云图。在绘图之前如图 3.6

所示选择单位，然后在图 3.7 软件自带的材料库中选择材料，最后如图 3.8 所示绘制模型结构。 

   

 图 3.5  Driven Terminal 方式 图 3.6  选择单位 

电磁场有限元求解需要设置端口（Port）和边界条件（Boundary Condition），一般在需要分

析的目标和参考平面（或者外边界）之间，绘制二维平面作为端口设置激励。端口分为波端口

（Wave Port）和集总端口（Lump Port）。一般暴露在外围边界处的端口设置为波端口，模型内

部的端口设置为集总端口。选择菜单 HFSS→Excitations→Assign→Lumped Port，如图 3.9 所示，
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在弹出的对话框中，设置端口名“1”，并选择另外的一个导体（GND-plane1）作为参考平面。 

 

图 3.7  选择材料 

 

图 3.8  绘制模型结构 

 

图 3.9  设置集总端口 
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通常在求解模型外部需要绘制一个空气盒子（airbox）作为求解区域，这个盒子需要包围

所有的互联结构，而且外延一定距离，这个距离通常在十分之一波长到四分之一波长之间，取

决于目标对外辐射能量的大小。选中这个空气盒子，选择菜单 HFSS→Boundaries→Assign→

Radiation…，选择 Radiating Only，如图 3.10 所示。 

 

图 3.10  设置 Radiation Boundary 

下面进行仿真求解设置，选择菜单 HFSS→Analysis Setup→Add Solution Setup。有关求解

频率、迭代次数和误差门限的设置如图 3.11 所示。 

 

图 3.11  仿真求解设置 

SI 仿真通常还需要宽带扫频，因此进行扫频设置，包括起止频率、取点数和扫频方式，

如图 3.12 所示。 

以上设置完成并检查（Validate）无误后，就可以开始仿真（Analyze All）了，如图 3.13

所示。 

HFSS 仿真结束后，可以在报告中输出 SYZ 参数，以及二维三维场图。选择菜单 HFSS→Results

→Create Terminal Solution Data Report→Rectangular Plot，可以输出 S 参数，结果如图 3.14 所示，

选择菜单 HFSS→Fields→Plot Fields→E→Mag_E，输出的二维三维场图如图 3.15 所示。 

Add Solution Setup
Toolbar 
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图 3.12  扫频设置 

 

图 3.13  检查和仿真 

 

图 3.14  输出 S 参数结果 

 

图 3.15  场图 

Add Sweep 
Toolbar 

Analyze All Validate
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3.3  Designer 软件 

3.3.1  Designer 概述 

Designer 是 ANSYS 公司推出的高性能信号完整性分析和 RFIC、MMIC、无线传输系统、

SoC，以及其他微波射频器件的设计平台。这个平台方便地集成了缜密的电磁场和复杂的电路

系统仿真功能，具有晶体管级的仿真精度、极大的电路容量、极高的仿真速度和杰出的收敛性。 

3.3.2  功能简介 

Designer 为高速电路和微波射频电路系统设计者提供一个全集成的图形化设计环境，实现

了原理图绘制、版图绘制和导入、电路设计和优化、参数扫描、敏感度分析、统计分析、仿真

结果后处理等全面功能。适用于多种高速信号传输总线设计，例如 XAUI、XFI、SATA、PCIE、

HDMI、DDRx 等总线构架。通过动态链接和 ANSYS 强大的电磁场分析软件：准静态电磁场

工具 Q3D、三维全波电磁场工具 HFSS，以及 PCB 板级 SI/PI/EMI 仿真工具 SIwave，协同进

行电路和电磁场仿真，方便地对 PCB、数模混合电路和高速串行通道的时域和频域进行仿真

分析，得到信号波形、眼图、同步开关噪声（SSN）、同步开关输出（SSO），电源/地的波动、

数模干扰等分析结果，高精度地完成 Gigabit 传输通道、高速存储总线和 EMI/EMC 设计。 

3.3.3  Designer 在信号完整性分析中的作用 

Designer 作为 ANSYS 高速电路仿真工具和集成化管理工具，在信号完整性分析中的主要

作用体现在以下几点： 

1．设计输入和管理 

Desinger 由灵活易用的原理图、版图编辑模块和高精度、大容量的可视化电路仿真引擎模

块组成。能够导入主流的 ECAD 版图设计工具（Cadence、Mentor Graphics、Zuken 和 Altium）

生成的 ODB++格式制造文件，或者 IC 宏模型、GDSII 或者 DXF 版图。Desinger 强大的设计

管理功能保证设计者能够将 S 参数、W-Element、HSPICE、Spectre 和 IBIS 作为电路原理图部

件，直接应用在同一原理图中，完成行为级、电路级和系统级的仿真。 

2．电路仿真能力 

Designer 电路仿真器为线性和非线性电路仿真提供了晶体管级精度，以及超强的仿真规模

和收敛性。电路仿真功能包括： 

（1）直流，交流，瞬态分析； 

（2）单音多音谐波分析，振荡分析，时变噪声分析，相噪分析； 

（3）包络仿真，牵引负载仿真，周期传递函数分析； 

（4）统计分析眼图： 

1）VerifyEye：使用统计算法对串行互联进行眼图分析的一种新方法。相对传统暂态算法

而言，仿真速度极大提高，并且保证仿真精度。 

2）QuickEye：基于线性叠加，使用快速卷积算法在数十秒内完成用户定义的数百万位数

据仿真。使用峰值失真分析（PDA）选项，QuickEye 会自动找出造成最大通道衰减的最坏激
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励码流。 

3）IBIS-AMI：与 QuickEye/VerifyEye 类似的快速分析算法。厂商编译后的器件库内可包

含均衡（Equalization）、串扰和时钟恢复（CDR）单元。 

3．动态链接 

Desinger 提供与 PCB 和三维电磁场设计工具 SIwave、HFSS 的双向动态链接功能，如图

3.16 所示。Designer 可以直接将 SIwave 和 HFSS 的仿真工程链接进 Desinger 设计中，作为一

个部件进行电路仿真和优化；电路仿真器仿真电路和系统的瞬态波形、仿真结果可以通过激励

推送方式，输出到 HFSS 和 SIwave 中，得到系统实际工作状态下的电磁辐射和传输特性。 

 

图 3.16  双向动态链接 

3.3.4  工作窗口 

Designer 基于 Windows 操作风格的界面，将项目管理窗口（Project Manager）、电路编辑

（scheme），以及属性（property）、信息（message）、进程（process）等辅助窗口集成在一个

界面下，如图 3.17 所示。所有的操作都可以通过菜单、工具栏、对话框、鼠标右键等方式快

捷完成，如图 3.18 所示。 

 

图 3.17  Designer 的工作窗口 
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图 3.18  快捷的操作 

3.3.5  基本操作 

Designer 在安装完成后，出现如下图标。 

 
双击打开后，选择需要仿真的电路类型。对于绝大多数 SI 问题，都使用图形化电路仿真

器，因此选择 Project→Insert→Insert Circuit Design，或者图标 。弹出如图 3.19 所示的对话

框，在 Technology 中选择 None。 

 

图 3.19  选择 technology 

打开的电路编辑环境中，在左侧的项目管理器中，第一栏 project 是当前设计状况显示，

第二栏 component 中是 Designer 自带的器件库，第三栏 serach 用于搜索器件模型。用户可以

导入自行获得的 SPICE 或 IBIS 模型库，选择 Tools→ Import SPICE Components/IBIS 

Components，如图 3.20 所示。Designer 中库的管理是分级的，包括系统库 syslib、用户库 userlib

和个人库 personallib。关于库的路径，可以在 Tools→Options→General Options 中指定。 

导入的器件库放在项目管理窗口的 Definitions 下的 components 中，选择导入的模型，直

接按住鼠标拖进电路中即可，如图 3.21 所示。 

如果需要导入电磁场仿真模型或者 S 参数结果，可以从菜单 Project→Add Model→Add 

Nport Model/…进入，指定动态链接模型路径和文件名。这时导入的模型放在项目管理窗口的

Properties window

Change to 10 in
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Definitions 下的 Models 中，同样以拖拽方式放入电路图中。模型互联可以用菜单 Draw→Wire

命令实现，或者拖拽器件使管脚相互接触后松开鼠标，再移动就可以。 

 

图 3.20  导入 SPICE 或 IBIS 模型库（左：导入 SPICE，右：导入 IBIS） 

 

图 3.21  调用模型 

完成电路设计后，执行 Circuit→Add Nexxim Solution Setup→…或者在项目管理窗口选中

Analysis，鼠标右击 Add Nexxim Solution Setup…>…，选择仿真类型，如图 3.22 所示。然后执

行菜单 Circuit→Anslysis，或者单击图标 开始仿真。 

 

图 3.22  建立分析 
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仿真结果可以选中项目管理窗口的 Results 项，或者鼠标右击选择 Create Standard Report

→Rectangular Plot，生成报告，如图 3.23 所示。 

 

图 3.23  生成报告 

3.4  SIwave 软件 

3.4.1  SIwave 概述 

SIwave 是 ANSYS 专用于 PCB、IC 封装、SiP 等进行信号完整性（SI）、电源完整性（PI）

以及电磁干扰（EMI）分析的软件。SIwave 使用全波有限元算法分析高速 PCB 单板和复杂

IC 封装上的谐振、反射、串扰、同步开关噪声、电源/地弹、直流电压/电流分布、近场和远

场辐射。适用于精确快速分析包含大规模复杂电源、地平面的 PCB 和封装设计，SIwave 采

用混合场求解技术，适合对多层平面结构 PCB 和封装结构提供直流、频域、时域分析，如

图 3.24 所示。 

3.4.2  功能简介 

SIwave 可以帮助工程师进行从 DC 到 10Gb/s 以上的信号、电源完整性、电磁辐射分析，

从PCB或封装设计版图中直接提取信号网络和电源分布网络的频域电路模型，输出到Designer

等 SPICE 兼容的电路仿真器当中，再结合芯片的 IBIS 或 SPICE 模型，确认信号和电源完整性

问题。也可以设置电压或电流激励源，仿真PCB或封装的远场和近场电磁辐射特性。与Designer

动态链接，可以导入实际工作信号的波形，进行精确的信号噪声辐射和干扰。SIwave 还可以

利用 IC 晶片（Die）网络建模器，对晶片上的硅效应进行建模，或者引入 Apache RedHawk 生

成的晶片模型进行同步翻转噪声（SSN）分析。SIwave 的直流分析得到的功率损耗，还可以
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作为热源导入到 ANSYS 热仿真工具当中，进行精确的热仿真。 

 

图 3.24  SIwave 功能 

3.4.3  SIwave 在信号完整性分析中的作用 

SIwave 通过导入 PCB 和封装等复杂结构的互联结构模型，使用电磁场仿真技术提取信号

和电源的分布参数，得到信号插损、回损、远端串扰（FEXT）、近端串扰（NEXT）、差分 S

参数及共模抑制比等。再结合 Designer 等电路仿真器，可实现信号时序、反射、串扰及同步

开关噪声的仿真。此外，SIwave 的谐振分析可以在设计初期，帮助设计师找到并抑制由于层

叠和布局带来的潜在电磁振荡危险，利用与 Designer 电路仿真工具的双向数据连接功能，加

入实际信号的波形作为干扰源，仿真 PCB 单板或封装的噪声分布、近场和远场辐射等指标，

仿真和优化 PCB 和封装的电磁兼容性能。 

除了仿真，SIwave 还具备版图和电路编辑功能，通过改变层叠、平面形状、走线，以及

无源 RLC 器件值，仿真这些因素对于信号、电源完整性和电磁辐射的影响，从而优化设计性

能。自带的电源完整性优化工具 PI_Advisor 还可以在设计前规划电源网络去耦电容的选取和

位置，在设计后进行电容成本、数量和性能的优化。 

3.4.4  工作窗口 

SIwave 基于 Windows 操作风格的界面，将版图编辑（Layout Editor），网络浏览（Nets）、

器件浏览（Components）、层叠显示（Layers），以及属性（property）、信息（message）、进程

（process）等辅助窗口集成在一个界面下。所有的操作都可以通过菜单、工具栏、对话框、鼠

标右键等方式快捷完成，如图 3.25 所示。 
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图 3.25  SIwave 的工作窗口 

3.4.5  基本操作 

SIwave 在安装完成后，桌面出现如下图标。 

 
双击打开后，首先需要通过菜单 File→Import→ANF 导入第三方 PCB 或封装设计通过

AnsoftLinks 接口输出的 anf 格式中间文件。导入的 PCB 或封装数据会与 Layout 设计环境中的

保持一致，包括网络、器件、层叠、键合丝、布线和平面。 

仿真之前需要设置，包括层叠材料特性、厚度、铜箔粗糙度、键合丝结构、焊球直径和

高速、过孔焊盘和反焊盘尺寸。这些信息如果已经在设计工具中设置好一些，会自动导入

SIwave 当中。执行菜单 Edit→Layer Stack….，或单击工具栏 进入层叠编辑窗口，如

图 3.26 所示。设置层叠材料特性、厚度、铜箔粗糙度。如果有特殊的材料，可以单击 Edit Material 

Properties 按钮添加新的材料。 

 

图 3.26  层叠编辑窗口 

Toolbars 

Layers 

Properties 

Information/Errors/Warnings

Menu bar 

Nets 

Results 

Components 

Messages 
 

Status bar 
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如果是封装或 SiP 设计，有 wirebonding 层，执行菜单 Edit→Bondwire Model 设置键合丝

属性，如图 3.27 所示。 

 

图 3.27  Bondwire 编辑窗口 

焊球、Solder Bump 和过孔焊盘编辑，执行菜单 Edit→Solder ball，Edit→Padstack，按照

提示输入参数即可。 

执行菜单 Edit→Circuit Elements，或者进入 Component 窗口，选择电容、电阻或电感，选

择 Local 类内的某款器件，如图 3.28 所示，鼠标右击 Edit Component Properties，就可以编辑

器件属性，如图 3.29 所示。 

   

 图 3.28  选择器件  图 3.29  编辑器件属性 

仿真之前执行菜单 Tools→Validation Check，先做规则检查，SIwave 会自动检查、定位并

修正一些开路、短路或交叠等错误。同时执行菜单 Simulation→Options，进行有关电磁场有限

元仿真的设置，通常默认设置如图 3.30 所示。 

检查完毕没有错误就可以开始仿真了。一开始 SIwave 中没有添加任何激励和端口时，在

Simulation 下只能做谐振分析 Resonent Analysis。在谐振分析中输入最高频率或谐振模式数，如
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图 3.31 所示，就可以开始仿真了。仿真完成后，结果通过执行菜单 Results→Resonant Modes→

Resonant Mode Sim 1→View Results 打开，显示了 PCB 或封装的谐振频率点，如图 3.32 所示。 

   

 图 3.30  电磁场有限元仿真的设置 图 3.31  谐振分析设置 

 

图 3.32  显示谐振频率点 

选中一种谐振模式后，选择某两个相邻平面层，如图 3.33 所示，单击 Compute 计算出每

个模式对应的谐振电压分布情况，如图 3.34 所示。 

   

 图 3.33  选择两个相邻两平面层  图 3.34  谐振电压分布情况 

对于关注的信号和电源网络，可以通过添加端口的方式，提取网络的 SYZ 参数。执行菜

单 Circuit Elements→Add Port，或者 Circuit Elements→Generate on Components/Generate on 
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Selected Nets…，可以通过 Layout 编辑界面手工添加端口，或者选中 Component 窗口中器件，

Net 窗口中的网络自动添加端口。执行菜单 Simulation→Compute S-, Y-, Z-parameters…，如图

3.35 所示，输入仿真频率范围、取点数目，就可以提取信号和电源网络的寄生参数。 

 

图 3.35  计算 SYZ 参数 

仿真结束后，执行菜单 Click Results→SYZ→SYZ Sweep 1→Plot Magnitude/Phase…，打开

SIwave Reporter 浏览 SYZ 参数，如图 3.36 所示。 

 

 

图 3.36  浏览 SYZ 参数 
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如果还需要时域仿真，执行菜单 Item Results→SYZ→SYZ Sweep 1→Compute FWS 

Subcircuit…，得到图 3.37。将仿真结果输出到 Designer 或其他 SPICE 兼容格式的模型，就可

用于电路仿真。 

 

图 3.37  计算全波 SPICE 子电路 

在 Designer 当中，提取的 PCB 信号线参数模型作为一个器件，加上激励源和负载后，得

到电路图 3.38，实现过冲、反射、串扰和时序等仿真，结果如图 3.39 所示。 

 

图 3.38  电路图 

 

图 3.39  仿真结果 
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对于一组总线的（包括一组信号线和电源网络）的大规模电路仿真，SIwave 推荐使用

SIwizard，自动实现多端口添加、参数提取、模型导入、仿真设置，快速实现场路协同仿真。 

3.5  Q2D（以前称 SI2D）/Q3D 软件 

3.5.1  Q2D/Q3D 概述 

随着器件的高速和高集成化发展，反射、传输延时、串扰、抖动等信号完整性问题越来

越突出，需要精确求解传输线、电缆的宽带寄生参数。Q2D/Q3D 是用于 PCB、芯片封装和电

源模块设计的二维/三维寄生参数提取工具。可以计算任意导电结构上寄生的频变电阻、电感、

电容、电导参数。准确地提取这些寄生参数对于仿真和验证高性能封装、连接器、汇流排和电

力电子转换器等复杂结构的性能非常关键。 

3.5.2  功能简介 

Q2D(SI2D)/Q3D 提供二维和三维建模、电磁场仿真和结果后处理集成化环境，从设计中

提取 RLGC 参数，并得到电流分布、电压分布、CG 和 RL 参数矩阵。软件能自动生成多种格

式的网表，包括 SML（Simplorer 格式）和 SPICE 模型，用于信号完整性和电磁兼容等领域的

仿真。Q2D/Q3D 还可以生成代表器件或无源互连网络的多端口网络参数的 Touchstone 格式的

S 参数。通过动态链接 Ansoft Desinger 和 Simplorer，仿真这些频变效果，还可用于提取大功

率汇流排、电缆和大功率逆变器/转换器封装的电阻、自电感和电容参数，在 Simplorer 中研究

电源系统的电磁兼容性能。Q3D 仿真技术如图 3.40 所示。 

 

图 3.40  Q3D 仿真技术 

3.5.3  Q2D/Q3D 在信号完整性分析中的作用 

Q2D 根据传输线、电缆的截面形状（2D）抽取寄生参数（RLGCZ0），生成 SPICE/IBIS

模型。Q2D 使用有限元法，根据截面形状（2D 模型）和材料特性，可以精确提取寄生参数。
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二维和三维结构准静态电磁场仿真，自动和自适应共形网格剖分，充分考虑金属趋肤效应和介

质损耗，直接计算结构的电容和导纳，交流、直流状态下的电阻、电感参数，传输线特性阻抗，

得到电荷分布、表面电流等结果，生成 SPICE 等效电路模型和 S 参数，进行 PCB、封装、电

缆、线束和连接器的设计和模型抽取，用于信号完整性前仿真的传输线规划。 

Q3D 可以根据三维互联结构的形状直接抽取寄生参数（RLGC），生成 SPICE/IBIS 模型。

ANSYS Q3D Extractor 使用边界元法，根据实际的三维模型和材料属性，可以精确快速提取寄

生参数模型，结合 Designer 等 SPICE 兼容的电路仿真器，用于封装、PCB、连接器、线缆等

信号完整性后仿真。Q3D 的准静态算法，相比 HFSS 的全波电磁场有限元算法，在求解结构

的频率上限，一般适合尺寸小于求解频率波长的 1/10 以内，如图 3.41 所示。 

 

图 3.41  Q3D 的适用范围 

3.5.4  工作窗口 

Q2D/Q3D 基于 Windows 操作风格的界面，将项目管理窗口（Project Manager）、建模窗口

（Modeler），以及属性（property）、信息（message）、进程（process）等辅助窗口集成在一个

界面下。图 3.42 是 Q2D 的工作窗口，图 3.43 是 Q3D 的工作窗口。所有的操作都可以通过菜

单、工具栏、对话框、鼠标右键等方式快捷完成。 

 

图 3.42  Q2D 的工作窗口 
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图 3.43  Q3D 的工作窗口 

3.5.5  基本操作 

Q3D 安装完后，桌面出现如下图标。 

 

双击打开后，选择二维 Q2D 求解器 或者三维 Q3D 求解器 。对于绝大多数 SI 前仿真

问题，以及具备沿信号传输方向结构一致的导体结构——如不换层的微带带状传输线、差分线、

平行导线、同轴线等——使用 Q2D 对导体和介质截面建模仿真。对于从结构设计攻击或 PCB

封装等电子设计工具导入的后模型进行 SI 后仿真，使用 Q3D 做三维模型的仿真。 

Q2D/Q3D 的仿真流程可以由图 3.44 概括。 

 

 

 

 

 

 

 

 

 

 

 

 

图 3.44  Q2D/Q3D 的仿真流程 
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Q2D/Q3D 为用户提供一个方便的二维/三维绘图建模环境（Q2D 二维模型设置长度后也可

以转为三维模型）。Q2D/Q3D 既可以在其中画出分析对象的三维结构，输入材料参数，进行仿

真分析，也可以导入 AutoCAD、Pro/E、STEP、IGES、ACIS

等机械结构设计文件，或者通过 AnsoftLinks 导入 PCB 或封

装的局部模型，设置材料和边界条件后直接做仿真。仿真结

果可以是 RLGC，生成 SPICE/IBIS 模型，或者扫频得到的 S

参数，也可以是三维或动画场云图。在绘图之前先如图 3.45

所示选择单位，然后如图 3.46 所示在软件自带的材料库中选

择材料，之后如图 3.47 所示绘制模型结构。 

 

图 3.46  选择材料 

 

图 3.47  绘制模型结构 

Q2D 模型创建完后，执行菜单 2D Extractor→Conductor→Auto Assign Signal，自动识别连接

在一起的金属导体作为一个网络。Q2D 使用二维有限元求解器，需要把导体中的至少一个设置为

参考地（Reference Ground），如图 3.48 所示。然后就可以设计求解，执行菜单 2D Extractor→Analysis 

Setup→Add Solution Setup…，选择求解频率，以及有限元迭代计算次数和，如图 3.49 所示。 

图 3.45  选择单位 
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 图 3.48  设置参考地 图 3.49  求解设置 

以上设置完成并检查（Validate）无误后，就可以开始仿真（Analyze All）了，如图 3.50

所示。 

 

图 3.50  检查和仿真 

仿真的结果，可以输出 RLC 参数，以及二维三维场图。执行菜单 2D Extractor→Results

→Solution data，可以看到寄生参数矩阵，如图 3.51 所示，也可以输出各种格式 SPICE 模型，

如图 3.52 所示，执行菜单 2D Extractor→Fields→CG Fields/RL Field 可以显示电场和磁场。 

 

图 3.51  寄生参数矩阵 

Q3D 的仿真过程与 Q2D 类似，执行菜单 Q3D Extractor→Conductor→Auto Assign Signal，

自动识别连接在一起的金属导体作为一个网络。Q3D 使用三维边界元准静态求解器，电容和

导纳计算与电阻和电感求解是独立的，求解一个网络的电阻电感和互感，就需要在导体截面上
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设置源（Source）和漏（Sink），指定电流流向，然后才可以设计求解。没有源（Source）和漏

（Sink）的导体只有电容，不计算电感电阻。如图 3.53 所示，在导体两端截面设置源（Source）

和漏（Sink）。 

 

图 3.52  输出各种格式 SPICE 模型 

 

图 3.53  设置源（Source）和漏（Sink） 

下面开始仿真求解设置，执行菜单 Q3D Extractor→Analysis Setup→Add Solution Setup。

有关求解设置、迭代次数和误差门限的设置如图 3.54 所示。 

以上设置完成并检查（Validate）无误后，就可以开始仿真（Analyze All）了，如图 3.55

所示。 

Q3D 仿真结束后，可以直接输出 RLC 参数，以及二维三维场图。也可以做矩阵消减（Reduce 

Matrix），无需重新求解，仿真不同信号分配、不同接地或者串并联、开路短路等对导体的寄

生参数影响。执行菜单 Q3D Extractor→Reduce Matrix→…，选择不同的矩阵消减类型。消减

矩阵的结果，可以在 Project Manager 窗口下的 Reduce Matrix 看到，如图 3.56 所示。 

Source4 

Rotate to the opposite end
of your trace by 180º 

Sink 4 
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图 3.54  求解设置 

 

图 3.55  检查和仿真 

 

图 3.56  消减矩阵的结果 

消减矩阵后的结果，执行菜单 Q3D Extractor→Results→Solution Data 可以看到如图 3.57

所示的寄生参数矩阵，也可以如图 3.58 所示输出各种格式 SPICE 模型，执行菜单 Q3D Extractor

→Fields→CG Fields/RL Field 可以显示电场和磁场，如图 3.59 所示。 

 

图 3.57  寄生参数矩阵 

Analyze All Validate

Add Solution Setup
Toolbar 
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图 3.58  输出各种格式 SPICE 模型 

 

图 3.59  显示电场和磁场 

 

 




